This is the topology I used:
R5 advertise the following networks: 192.168.51.0/24, 192.168.52.0/24
and 192.168.53.0/24
On R5 I have configured a route-map which will tag every
path through every router:
ip prefix-list PL_NET5x seq 5
permit 192.168.51.0/24
ip prefix-list PL_NET5x seq
10 permit 192.168.52.0/24
ip prefix-list PL_NET5x seq
15 permit 192.168.53.0/24
!
route-map RM_OUT_TAG permit
20
match ip address prefix-list PL_NET5x
match interface FastEthernet2/0
set tag 22
!
route-map RM_OUT_TAG permit
30
match ip address prefix-list PL_NET5x
match interface FastEthernet1/1
set tag 33
!
route-map RM_OUT_TAG permit
40
match ip address prefix-list PL_NET5x
match interface FastEthernet1/0
set tag 44
!
router eigrp 1
distribute-list route-map RM_OUT_TAG out
network 0.0.0.0
|
Each router got his tag for R5 networks path.
On R1 I have configured route-map which change the metric
for each path:
route-map RM_INBOUND_PREF
permit 10
match tag 44
set metric 100000 10 255 1 1500
!
route-map RM_INBOUND_PREF
permit 20
match tag 33
set metric 10000 10 255 1 1500
!
route-map RM_INBOUND_PREF
permit 30
match tag 22
set metric 1000 10 255 1 1500
!
router eigrp 1
distribute-list route-map RM_INBOUND_PREF in
network 0.0.0.0
|
Note the syntax for setting up metric for EIGRP under route-map.
Now R1 will prefer R4 path to R5 network, R3 and R2 will be
candidate path in case of failure accordingly.
R1 topology view, notice the different metric each path has:
R1#sh ip eigrp topology
EIGRP-IPv4 Topology Table for
AS(1)/ID(192.168.13.1)
Codes: P - Passive, A - Active,
U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.51.0/24, 1
successors, FD is 158720, tag is 44, U
via 10.1.14.4 (158720/156160),
FastEthernet2/0
via 10.1.13.3 (258560/156160), FastEthernet1/1
via 10.1.12.2 (2562560/156160),
FastEthernet1/0
P 192.168.52.0/24, 1
successors, FD is 158720, tag is 44, U
via 10.1.14.4 (158720/156160),
FastEthernet2/0
via 10.1.13.3 (258560/156160),
FastEthernet1/1
via 10.1.12.2 (2562560/156160),
FastEthernet1/0
P 192.168.53.0/24, 1
successors, FD is 158720, tag is 44, U
via 10.1.14.4 (158720/156160),
FastEthernet2/0
via 10.1.13.3 (258560/156160),
FastEthernet1/1
via 10.1.12.2 (2562560/156160),
FastEthernet1/0
<OUTPUT_OMMITED>
|
The tag and route-map usage allows us to control and
manipulate traffic paths on per-router, per-prefix basis and to gain load-balance
with redundancy.
No comments:
Post a Comment