Lab topology is hub and spoke, where R1 is the spoke and R3
and R4 are the spokes.
First I configured R2 as frame-relay switch:
frame-relay switching
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 103 interface Serial0/1
301
frame-relay route 104 interface Serial0/2
401
!
interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 301 interface Serial0/0
103
!
interface Serial0/2
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 401 interface Serial0/0
104
!
|
The configure R1 in point-to-multipoint manner:
interface Serial0/0.1
multipoint
ip address 10.1.134.1 255.255.255.0
snmp trap link-status
no arp frame-relay
frame-relay map ip 10.1.134.3 103 broadcast
frame-relay map ip 10.1.134.4 104 broadcast
frame-relay interface-dlci 103
frame-relay interface-dlci 104
no frame-relay inverse-arp
!
|
And R3 and R4 in point-to-point manner:
R3:
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
!
interface Serial0/0.1
point-to-point
ip address 10.1.134.3 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 301
no arp frame-relay
no frame-relay inverse-arp
!
|
R4:
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
!
interface Serial0/0.1
point-to-point
ip address 10.1.134.4 255.255.255.0
snmp trap link-status
no arp frame-relay
frame-relay interface-dlci 401
!
|
Then configuring OSPF on all 3 routers advertising loopback
1 and serial0/0.1 on each, waiting few minutes and nothing happen…no adjacency,
no neighbors!
Let’s look on R1 OSPF interface:
R1#show
ip ospf interface serial 0/0.1
Serial0/0.1 is up, line
protocol is up
Internet Address 10.1.134.1/24, Area 0
Process ID 1, Router ID 192.168.11.1, Network Type NON_BROADCAST,
Cost: 64
Transmit Delay is 1 sec, State DR, Priority
1
Designated Router (ID) 192.168.11.1,
Interface address 10.1.134.1
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120,
Retransmit 5
oob-resync timeout 120
Hello due in 00:00:05
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is
0 msec
Neighbor Count is 0, Adjacent neighbor
count is 0
Suppress hello for 0 neighbor(s)
|
And on R3 OSPF interface:
R3#show ip ospf interface
serial 0/0.1
Serial0/0.1 is up, line
protocol is up
Internet Address 10.1.134.3/24, Area 0
Process ID 1, Router ID 192.168.31.1, Network Type POINT_TO_POINT,
Cost: 64
Transmit Delay is 1 sec, State
POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40,
Retransmit 5
oob-resync timeout 40
Hello due in 00:00:05
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is
0 msec
Neighbor Count is 0, Adjacent neighbor
count is 0
Suppress hello for 0 neighbor(s)
|
See the problem…
In order to solve the problem I will change the topology to on
all routers to OSPF network type to point-to-multipoint which is the most ideal
for NBMA topology:
R1-R3-R4:
interface Serial0/0.1
ip ospf network point-to-multipoint
!
|
The result:
-
All updates are multicast
-
No DR/BDR election
-
Timers 30/120
-
No neighbor statements
-
Modify next-hop occurs
R4#show ip route
Codes: C - connected, S -
static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O -
OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 -
OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF
external type 2
i - IS-IS, su - IS-IS summary, L1 -
IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate
default, U - per-user static route
o - ODR, P - periodic downloaded
static route
Gateway of last resort is not
set
O 192.168.31.0/24 [110/129] via 10.1.134.1, 00:03:26,
Serial0/0.1
192.168.11.0/32 is subnetted, 1 subnets
O 192.168.11.1 [110/65] via 10.1.134.1,
00:03:26, Serial0/0.1
C 192.168.41.0/24 is directly connected,
Loopback1
10.0.0.0/8 is variably subnetted, 3
subnets, 2 masks
O 10.1.134.1/32 [110/64] via 10.1.134.1,
00:03:26, Serial0/0.1
C 10.1.134.0/24 is directly connected,
Serial0/0.1
O 10.1.134.3/32 [110/128] via 10.1.134.1,
00:03:26, Serial0/0.1
|
Next lab – OSPF PtP partial mesh.
No comments:
Post a Comment