This time I will configure OSPFv3 network, I will use the
following network topology:
Since I realize that I might need to configure router as
frame-relay switch, in the exam, I don’t use the GNS built-in frame-relay switch anymore.
So the following setup is very clear and simple beside the
fact that R1 and R2 are connected through frame-relay cloud in NBMA mode and
not in PtP (which is much easier to
config). Also all IPv6 addresses are derived using EUI-64.
So the FRS config:
frame-relay switching
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 128000
frame-relay interface-dlci 102
load-interval 30
frame-relay intf-type dce
frame-relay route 102 interface Serial0/1 201
!
interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 128000
frame-relay interface-dlci 201
load-interval 30
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0 102
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 128000
frame-relay interface-dlci 102
load-interval 30
frame-relay intf-type dce
frame-relay route 102 interface Serial0/1 201
!
interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 128000
frame-relay interface-dlci 201
load-interval 30
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0 102
R1 Config:
ipv6 unicast-routing
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
ipv6 address 2001:FE:13:13::/64 eui-64
ipv6 ospf 1 area 13
!
interface Serial0/0
ip address 10.1.12.1 255.255.255.0
encapsulation frame-relay
ipv6 address 2001:FE:12:12::/64 eui-64
ipv6 ospf neighbor FE80::C201:1BFF:FEC8:0
ipv6 ospf 1 area 0
clock rate 2000000
no arp frame-relay
frame-relay map ipv6 FE80::C201:1BFF:FEC8:0 102 broadcast
frame-relay interface-dlci 102
no frame-relay inverse-arp
!
no ip address
speed 100
full-duplex
ipv6 address 2001:FE:13:13::/64 eui-64
ipv6 ospf 1 area 13
!
interface Serial0/0
ip address 10.1.12.1 255.255.255.0
encapsulation frame-relay
ipv6 address 2001:FE:12:12::/64 eui-64
ipv6 ospf neighbor FE80::C201:1BFF:FEC8:0
ipv6 ospf 1 area 0
clock rate 2000000
no arp frame-relay
frame-relay map ipv6 FE80::C201:1BFF:FEC8:0 102 broadcast
frame-relay interface-dlci 102
no frame-relay inverse-arp
!
ipv6 router ospf 1
router-id 1.1.1.1
log-adjacency-changes
router-id 1.1.1.1
log-adjacency-changes
R2 Config:
ipv6 unicast-routing
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
ipv6 address 2001:FE:24:24::/64 eui-64
ipv6 ospf 1 area 24
!
interface Serial0/0
ip address 10.1.12.2 255.255.255.0
encapsulation frame-relay
ipv6 address 2001:FE:12:12::/64 eui-64
ipv6 ospf neighbor FE80::C200:1BFF:FEC8:0
ipv6 ospf 1 area 0
clock rate 2000000
frame-relay map ipv6 FE80::C200:1BFF:FEC8:0 201 broadcast
frame-relay interface-dlci 201
!
ipv6 router ospf 1
router-id 2.2.2.2
log-adjacency-changes
interface FastEthernet0/0
no ip address
speed 100
full-duplex
ipv6 address 2001:FE:24:24::/64 eui-64
ipv6 ospf 1 area 24
!
interface Serial0/0
ip address 10.1.12.2 255.255.255.0
encapsulation frame-relay
ipv6 address 2001:FE:12:12::/64 eui-64
ipv6 ospf neighbor FE80::C200:1BFF:FEC8:0
ipv6 ospf 1 area 0
clock rate 2000000
frame-relay map ipv6 FE80::C200:1BFF:FEC8:0 201 broadcast
frame-relay interface-dlci 201
!
ipv6 router ospf 1
router-id 2.2.2.2
log-adjacency-changes
R3 Config:
ipv6 unicast-routing
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
ipv6 address 2001:FE:13:13::/64 eui-64
ipv6 address FC01:DB8:74:B::/64 eui-64
ipv6 ospf 1 area 13
!
ipv6 router ospf 1
router-id 3.3.3.3
log-adjacency-changes
interface FastEthernet0/0
no ip address
speed 100
full-duplex
ipv6 address 2001:FE:13:13::/64 eui-64
ipv6 address FC01:DB8:74:B::/64 eui-64
ipv6 ospf 1 area 13
!
ipv6 router ospf 1
router-id 3.3.3.3
log-adjacency-changes
R4 Config:
ipv6 unicast-routing
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
ipv6 address 2001:FE:24:24::/64 eui-64
ipv6 ospf 1 area 24
!
ipv6 router ospf 1
router-id 4.4.4.4
log-adjacency-changes
no ip address
speed 100
full-duplex
ipv6 address 2001:FE:24:24::/64 eui-64
ipv6 ospf 1 area 24
!
ipv6 router ospf 1
router-id 4.4.4.4
log-adjacency-changes
Points of interest in this lab:
The Frame-relay connection between R1 and R2 is done using NBMA which dictate LSA flooding using unicast hence a neighbor statement should be configured, but unlike IPv4, in IPv6 we need to configure this statement using the link-local IPv6 and not the interface IPv6 which in this case it's global-unicast address. Also frame-relay IPv6 static maps should be configured.
OSPFv3 is configured directly on the interface but in order to achieve adjacency we will need to configure router-id, which done under ipv6 router ospf process.
No comments:
Post a Comment